summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJesse Luehrs <doy@tozt.net>2021-11-10 12:46:34 -0500
committerJesse Luehrs <doy@tozt.net>2021-11-10 12:46:34 -0500
commit847f8834ae051c1c6177e9166cac855ccff113f0 (patch)
tree4dddd900383673b55414522573309e86b11fe209 /Cargo.toml
parent165033dd11cb6d200b9b9233840dff96e6468e0d (diff)
downloadnbsh-847f8834ae051c1c6177e9166cac855ccff113f0.tar.gz
nbsh-847f8834ae051c1c6177e9166cac855ccff113f0.zip
fix some dependencies
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml8
1 files changed, 5 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 9bed95f..dfb8dc4 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -3,15 +3,17 @@ name = "nbsh"
version = "0.1.0"
edition = "2021"
+license = "MIT"
+
[dependencies]
anyhow = "1.0.45"
-async-process = "1.2.0"
+async-process = "1.3.0"
async-std = "1.10.0"
futures = "0.3.17"
libc = "0.2.107"
nix = "0.23.0"
-pty-process = { version = "0.1.0", features = ["backend-async-std"] }
-textmode = { version = "0.1.0", features = ["async"] }
+pty-process = { version = "0.1.1", features = ["backend-async-std"] }
+textmode = { version = "0.1.1", features = ["async"] }
vt100 = "0.12.0"
[features]