aboutsummaryrefslogtreecommitdiffstats
Commit message (Collapse)AuthorAgeFilesLines
* actually, what am i doingHEADmasterJesse Luehrs2014-11-011-3/+1
|
* stop using slots directly hereJesse Luehrs2014-11-011-3/+3
|
* not using this anymoreJesse Luehrs2014-11-011-2/+0
|
* test for built-in python equivalents of override_test.pyJesse Luehrs2014-11-011-0/+138
|
* let's just not have new at allJesse Luehrs2014-11-011-5/+3
|
* use python-style constructorsJesse Luehrs2014-11-014-79/+84
|
* call hash(), not __hash__()Jesse Luehrs2014-11-012-3/+3
|
* fix commentJesse Luehrs2014-11-011-2/+1
|
* actually, these base method belong in phase 3Jesse Luehrs2014-11-011-7/+7
|
* the metaclass is already set hereJesse Luehrs2014-11-011-4/+2
|
* simplify the initial phase of the bootstrap a bitJesse Luehrs2014-11-011-31/+31
|
* remove useless get_ prefixesJesse Luehrs2014-11-015-101/+101
|
* also replace the hardcoded gen_reader stuffJesse Luehrs2014-11-011-0/+15
|
* better handling of Method.executeJesse Luehrs2014-11-011-15/+27
|
* readmeJesse Luehrs2014-11-011-0/+5
|
* clean up the bootstrap testJesse Luehrs2014-11-011-10/+9
|
* durrJesse Luehrs2014-11-011-5/+4
|
* bunch more testsJesse Luehrs2014-11-014-93/+298
|
* make the constructor go through the attribute protocol as wellJesse Luehrs2014-11-011-15/+16
|
* test a few simple overridesJesse Luehrs2014-10-311-0/+93
|
* expand the testsJesse Luehrs2014-10-311-3/+38
|
* also set_valueJesse Luehrs2014-10-311-0/+6
|
* more meaningful names hereJesse Luehrs2014-10-311-7/+7
|
* testsJesse Luehrs2014-10-311-0/+5
|
* use a better reader implementation for most thingsJesse Luehrs2014-10-311-6/+13
| | | | it goes through the attribute protocol whenever possible
* a few testsJesse Luehrs2014-10-312-0/+87
|
* looks like we do need a separate finalize stepJesse Luehrs2014-10-311-3/+8
| | | | | otherwise inheritance doesn't work, because there's no point at which we can really initialize the backing vtable for the ancestor class methods
* add an attribute method to get the value at that attributeJesse Luehrs2014-10-311-0/+6
|
* actually, looks like we do need to support defaultsJesse Luehrs2014-10-311-5/+29
| | | | | otherwise Class's methods and attributes attributes won't be properly initialized
* these don't need to be globalJesse Luehrs2014-10-311-34/+32
|
* more commentsJesse Luehrs2014-10-311-0/+9
|
* various cleanupsJesse Luehrs2014-10-311-27/+70
|
* don't use the class name as the keyJesse Luehrs2014-10-311-6/+10
| | | | it's not necessarily unique
* the real add_method should use methodsJesse Luehrs2014-10-311-1/+1
|
* more refactoringJesse Luehrs2014-10-311-6/+15
|
* clean up the pre-bootstrap stuff a bitJesse Luehrs2014-10-311-27/+34
|
* initial sketchJesse Luehrs2014-10-312-0/+203