aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorJesse Luehrs <doy@tozt.net>2014-09-22 23:05:30 -0400
committerJesse Luehrs <doy@tozt.net>2014-09-22 23:20:23 -0400
commit931ebeabf4a378b303f6868d34ca66b433d28188 (patch)
treebee094449a09d7f857478abc450c120300320d6d /setup.py
parent10b2ea0a4876a9ecaae7ab58265ad623b2aa7027 (diff)
downloadpython-termcast-client-931ebeabf4a378b303f6868d34ca66b433d28188.tar.gz
python-termcast-client-931ebeabf4a378b303f6868d34ca66b433d28188.zip
package this up as a script
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py19
1 files changed, 19 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..eb437fa
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,19 @@
+from setuptools import setup, find_packages
+
+setup(
+ name="termcast_client",
+ version="0.1.0",
+ description="broadcast your terminal sessions for remote viewing",
+ url="https://github.com/doy/python-termcast-client",
+ author="Jesse Luehrs",
+ author_email="doy@tozt.net",
+ license="MIT",
+ classifiers=[
+ ],
+ packages=find_packages(),
+ entry_points={
+ "console_scripts": [
+ "termcast=termcast_client:main",
+ ],
+ },
+)