aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorJesse Luehrs <doy@tozt.net>2014-09-23 14:14:45 -0400
committerJesse Luehrs <doy@tozt.net>2014-09-23 14:14:45 -0400
commita7e6b8683c1989f3a9b155336e8a4d314fe7bb8b (patch)
tree90a79aec508f503456c5fc6c418ad7de70659260 /setup.py
parent70cd632270083acc2bb835069d6e00f07a728cb3 (diff)
downloadpython-termcast-server-a7e6b8683c1989f3a9b155336e8a4d314fe7bb8b.tar.gz
python-termcast-server-a7e6b8683c1989f3a9b155336e8a4d314fe7bb8b.zip
packaging
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py23
1 files changed, 23 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..04b3fcc
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,23 @@
+from setuptools import setup, find_packages
+
+setup(
+ name="termcast_server",
+ version="0.1.0",
+ description="allow users to broadcast their terminals for others to watch",
+ url="https://github.com/doy/python-termcast-server",
+ author="Jesse Luehrs",
+ author_email="doy@tozt.net",
+ license="MIT",
+ classifiers=[
+ "Development Status :: 3 - Alpha",
+ "Environment :: Console",
+ "License :: OSI Approved :: MIT License",
+ "Topic :: Terminals :: Terminal Emulators/X Terminals",
+ ],
+ packages=find_packages(),
+ entry_points={
+ "console_scripts": [
+ "termcast_server=termcast_server:main",
+ ],
+ },
+)