aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJesse Luehrs <doy@tozt.net>2020-04-06 06:35:30 -0400
committerJesse Luehrs <doy@tozt.net>2020-04-06 06:35:30 -0400
commitbc18bca5c67b4a678a31198877e39d57d97b1e0c (patch)
tree3dc31608586cbe0f7973d7aa730267d57224e6a1 /Cargo.toml
parent4ad2f0a0dc3abb4cb10a6b82ca6a1f3a829eb1fb (diff)
downloadrbw-bc18bca5c67b4a678a31198877e39d57d97b1e0c.tar.gz
rbw-bc18bca5c67b4a678a31198877e39d57d97b1e0c.zip
factor out into an agent
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 4 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index c9be52f..d4743ff 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -8,6 +8,8 @@ edition = "2018"
aes = "*"
base64 = "*"
block-modes = "*"
+directories = "*"
+fs2 = "*"
hkdf = "*"
hmac = "*"
pbkdf2 = "*"
@@ -15,6 +17,8 @@ reqwest = { version = "*", features = ["blocking", "json"] }
rpassword = "*"
rprompt = "*"
serde = { version = "*", features = ["derive"] }
+serde_json = "*"
sha2 = "*"
snafu = "*"
+tokio = { version = "*", features = ["full"] }
uuid = { version = "*", features = ["v4"] }