aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJesse Luehrs <doy@tozt.net>2020-04-05 02:17:25 -0400
committerJesse Luehrs <doy@tozt.net>2020-04-05 02:17:25 -0400
commitcd894c27e0b0d5746b95b9c2933da3ba6e9a3f5b (patch)
tree94de4da0e8ac1cea7a855f8fb1d16d6f320e7e72 /Cargo.toml
parent070315ce5f80e82fcb5f39c15cd7bbf1682fdf8b (diff)
downloadrbw-cd894c27e0b0d5746b95b9c2933da3ba6e9a3f5b.tar.gz
rbw-cd894c27e0b0d5746b95b9c2933da3ba6e9a3f5b.zip
basic implementation of the cryptographic stuff
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml15
1 files changed, 13 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 69fd9ee..c9be52f 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -4,6 +4,17 @@ version = "0.1.0"
authors = ["Jesse Luehrs <doy@tozt.net>"]
edition = "2018"
-# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
-
[dependencies]
+aes = "*"
+base64 = "*"
+block-modes = "*"
+hkdf = "*"
+hmac = "*"
+pbkdf2 = "*"
+reqwest = { version = "*", features = ["blocking", "json"] }
+rpassword = "*"
+rprompt = "*"
+serde = { version = "*", features = ["derive"] }
+sha2 = "*"
+snafu = "*"
+uuid = { version = "*", features = ["v4"] }