aboutsummaryrefslogtreecommitdiffstats
Commit message (Collapse)AuthorAgeFilesLines
...
* factor some stuff out of SummaryReporterJesse Luehrs2013-02-282-43/+51
|
* nicer sbt test outputJesse Luehrs2013-02-281-2/+2
|
* more cleanupsJesse Luehrs2013-02-281-3/+3
|
* clean upsJesse Luehrs2013-02-284-19/+23
|
* eh, skip all with no message isn't worth it, reallyJesse Luehrs2013-02-283-40/+6
|
* better gitignoreJesse Luehrs2013-02-281-2/+1
|
* add todo list for things i don't feel like doing at the momentJesse Luehrs2013-02-281-0/+4
|
* more cleanupJesse Luehrs2013-02-281-16/+16
|
* refactor the harness application a bitJesse Luehrs2013-02-281-18/+50
|
* test for explicit plans with TestMoreJesse Luehrs2013-02-281-0/+29
|
* eliminate MessageJesse Luehrs2013-02-286-176/+223
|
* case class cleanupsJesse Luehrs2013-02-283-27/+12
|
* stop using Option[Plan]Jesse Luehrs2013-02-285-46/+50
|
* make some more things privateJesse Luehrs2013-02-283-27/+26
|
* try to name this a bit betterJesse Luehrs2013-02-278-20/+24
|
* couple more testsJesse Luehrs2013-02-272-2/+4
|
* add a leading newline to diags when running under a non-raw reporterJesse Luehrs2013-02-277-35/+72
| | | | | makes things easier to read this way, when diags are printed to stderr interspersed with test summary information
* use the new stream parsing stuff in the summary reporterJesse Luehrs2013-02-271-16/+66
|
* this name parameter was never usedJesse Luehrs2013-02-272-23/+8
|
* short summary goes after long summaryJesse Luehrs2013-02-271-1/+1
|
* use iterators instead of streamsJesse Luehrs2013-02-271-16/+16
| | | | | | | | | streams buffer the next character (to support Stream.Empty), which means that if there is exactly one line available, it will read that line and then block waiting for the next character before the result stream can be returned. this means that we don't get results from the current line until the next line is ready. iterators don't have that problem, since they don't have a separate Empty type, they just have a hasNext method.
* also generate start and end eventsJesse Luehrs2013-02-271-2/+9
|
* generate plan and result eventsJesse Luehrs2013-02-261-3/+9
| | | | ignore comments and subtests completely for now
* these don't need to be publicJesse Luehrs2013-02-261-2/+2
|
* use a recursive call rather than a varJesse Luehrs2013-02-261-18/+23
| | | | | a bit more complicated than i'd like, due to path-dependent types, but oh well
* more cleanupJesse Luehrs2013-02-261-13/+7
|
* split out the tap stream parser from the individual line parsersJesse Luehrs2013-02-267-308/+293
|
* make this a lazy val tooJesse Luehrs2013-02-261-1/+1
|
* more refactoringJesse Luehrs2013-02-261-50/+52
|
* simplifyJesse Luehrs2013-02-261-94/+53
|
* make a couple more traits sealedJesse Luehrs2013-02-262-3/+3
|
* simplifyJesse Luehrs2013-02-261-5/+6
|
* using streams is cleaner hereJesse Luehrs2013-02-261-37/+36
|
* rewrite the tap parserJesse Luehrs2013-02-261-77/+313
| | | | | | | | this parser is line based, which should make the top level logic easier to understand (although it does push some hairy stuff down to the bottom that i still need to clean up). it also should be able to be easily modified to work as a streaming parser, although i haven't tried to do that yet.
* make the test method hiding stuff a bit less fragile. hopefully.Jesse Luehrs2013-02-252-31/+40
|
* make this a bit cleanerJesse Luehrs2013-02-252-4/+2
|
* styleJesse Luehrs2013-02-254-4/+4
|
* comment that, because it's a bit non-obviousJesse Luehrs2013-02-251-0/+9
|
* make sure stdout and stderr are synchronized when possibleJesse Luehrs2013-02-251-1/+7
|
* switch back to (a simpler form of) tests reporting their exit codeJesse Luehrs2013-02-255-18/+18
|
* oops, include the passing version of this testJesse Luehrs2013-02-241-1/+1
|
* allow running external programs as tap producersJesse Luehrs2013-02-243-0/+55
|
* don't need scalatest anymoreJesse Luehrs2013-02-231-2/+0
|
* a bit more cleanupJesse Luehrs2013-02-235-7/+7
|
* clean up importsJesse Luehrs2013-02-2313-79/+57
|
* simplifyJesse Luehrs2013-02-231-3/+2
|
* clean up plan object creation a bitJesse Luehrs2013-02-233-5/+5
|
* don't need this anymore since it was moved inside the classJesse Luehrs2013-02-231-8/+5
|
* make tap line numbers more stable in these testsJesse Luehrs2013-02-232-15/+21
|
* tests shouldn't produce anything other than tapJesse Luehrs2013-02-2311-90/+137
| | | | the harness can parse the tap to figure out whatever it needs from that