summaryrefslogtreecommitdiffstats
Commit message (Expand)AuthorAgeFilesLines
* add test for loading just the syntax on its ownxslate-more-opcodesJesse Luehrs2012-10-193-10/+75
* find_file and suffix are now opcodesJesse Luehrs2012-10-192-11/+17
* simplify the logic for template suffixesJesse Luehrs2012-10-194-42/+24
* move most of find_file into the compilerJesse Luehrs2012-10-192-8/+41
* simplifyJesse Luehrs2012-10-191-10/+12
* avoid calling find_file multiple timesJesse Luehrs2012-10-191-8/+20
* don't constant-fold render_stringJesse Luehrs2012-10-181-1/+3
* merge_hash is now an opcodeJesse Luehrs2012-10-182-5/+22
* reimplement new_vars_for in terms of merge_hashJesse Luehrs2012-10-182-28/+149
* turned render_string into an opcodeJesse Luehrs2012-10-152-11/+5
* reimplement run_code in terms of render_stringJesse Luehrs2012-10-152-11/+74
* is_code_ref can now be an opcode tooJesse Luehrs2012-10-152-7/+14
* this weaken is unnecessaryJesse Luehrs2012-10-151-2/+1
* simplifyJesse Luehrs2012-10-141-13/+6
* this doesn't need to be a function eitherJesse Luehrs2012-10-142-11/+53
* neither does make_hashJesse Luehrs2012-10-142-5/+11
* make_array doesn't need to be a functionJesse Luehrs2012-10-142-6/+12
* generate the opcodes for this directlyJesse Luehrs2012-10-141-1/+44
* changelog0.01Jesse Luehrs2012-10-081-0/+2
* fix gitignoreJesse Luehrs2012-10-081-1/+1
* pod coverageJesse Luehrs2012-10-082-0/+37
* remove the abstract hereJesse Luehrs2012-10-081-1/+0
* don't index internal classesJesse Luehrs2012-10-081-0/+5
* docsJesse Luehrs2012-10-081-0/+155
* rename this to just Text::HandlebarsJesse Luehrs2012-10-082-3/+3
* make this a bit more explicitJesse Luehrs2012-10-082-1/+7
* this is already a built-in thingJesse Luehrs2012-10-082-5/+1
* check partial suffix at runtime, not compile timeJesse Luehrs2012-10-082-17/+4
* move more code into the compilerJesse Luehrs2012-10-082-143/+143
* simplifyJesse Luehrs2012-10-082-10/+21
* move more bits into the compilerJesse Luehrs2012-10-082-16/+41
* implement hash args for normal helpersJesse Luehrs2012-10-083-5/+10
* implement hash parameters for block helpersJesse Luehrs2012-10-084-7/+59
* make block helpers recognizable as helpersJesse Luehrs2012-10-082-8/+8
* move this earlierJesse Luehrs2012-10-051-10/+10
* and... didn't need these parts of that fileJesse Luehrs2012-10-051-8/+0
* whoops, forgot to add this file a while agoJesse Luehrs2012-10-051-0/+22
* rename a few thingsJesse Luehrs2012-10-052-6/+6
* move lambda checking for keys out of the parserJesse Luehrs2012-10-052-43/+64
* simplify the parsing logic significanly by redefining expressionJesse Luehrs2012-10-051-50/+25
* simplifyJesse Luehrs2012-10-051-8/+12
* restructure this to mirror expression() more closelyJesse Luehrs2012-10-051-1/+2
* this went away a while agoJesse Luehrs2012-10-051-3/+1
* since functions and helpers are different, drop this special caseJesse Luehrs2012-10-052-5/+14
* change back to defining helpers and functions separatelyJesse Luehrs2012-10-056-18/+55
* why was i defining things there?Jesse Luehrs2012-10-052-25/+20
* remove debugging codeJesse Luehrs2012-10-051-1/+0
* hack to make normal helpers work for nowJesse Luehrs2012-10-052-3/+12
* Another test for "each" setting up context correctlyShawn M Moore2012-10-051-0/+25
* special case {{{.}}} (not dealing with {{foo . bar}} in general)Jesse Luehrs2012-10-052-12/+16