aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJesse Luehrs <doy@tozt.net>2021-12-04 02:08:27 -0500
committerJesse Luehrs <doy@tozt.net>2021-12-04 02:08:27 -0500
commit33cc13b554e6f4cc6e139b0eecf5c6e697433a9d (patch)
tree59a6558bb7f824852f823d6a9d47c9034c3ab613 /Cargo.toml
parent922151a0ad78027a54e6d0da6555117493e67ef8 (diff)
downloadttyrec-bin-33cc13b554e6f4cc6e139b0eecf5c6e697433a9d.tar.gz
ttyrec-bin-33cc13b554e6f4cc6e139b0eecf5c6e697433a9d.zip
initial implementation
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml9
1 files changed, 9 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 519c6ab..ebdb3f9 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -6,3 +6,12 @@ edition = "2021"
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
[dependencies]
+anyhow = "1.0.51"
+async-std = { version = "1.10.0", features = ["unstable"] }
+libc = "0.2.108"
+paw = "1.0.0"
+pty-process = { version = "0.1.1", features = ["backend-async-std"] }
+structopt = { version = "0.3.25", features = ["paw", "wrap_help"] }
+terminal_size = "0.1.17"
+textmode = { version = "0.2.0", features = ["async"] }
+ttyrec = { path = "../ttyrec", version = "0.2.0", features = ["async"] }