summaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL15
1 files changed, 13 insertions, 2 deletions
diff --git a/Makefile.PL b/Makefile.PL
index ca871d7..0f4899d 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -5,10 +5,21 @@ use inc::Module::Install;
name 'Language-TECO';
all_from 'lib/Language/TECO.pm';
-requires '';
+feature 'Command line te script' =>
+ -default => 1,
+ 'Term::ReadKey' => '0';
+
+feature 'IRC evalbot' =>
+ -default => 0,
+ 'Bot::BasicBot' => '0';
build_requires 'Test::More';
+build_requires 'Test::Exception';
+
+install_script('bin/te');
+install_script('bin/tecobot');
+
+tests 't/*.t';
auto_install;
WriteAll;
-