aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJesse Luehrs <doy@tozt.net>2019-07-09 03:14:26 -0400
committerJesse Luehrs <doy@tozt.net>2019-07-09 03:14:26 -0400
commit2510f46e32ade9f7c3f6d2546e8a7338f4c27cd7 (patch)
treeb9cfd00badd10e9805e676ad2c3ea638c032694e /Cargo.toml
parent4f593b410b7d66a8f5e2d0e970f59854938926a7 (diff)
downloadnbsh-old-2510f46e32ade9f7c3f6d2546e8a7338f4c27cd7.tar.gz
nbsh-old-2510f46e32ade9f7c3f6d2546e8a7338f4c27cd7.zip
use context instead of map_err for futures and streams
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 6792a5e..a7a6deb 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -15,6 +15,6 @@ crossterm = "0.9"
futures = "0.1"
mio = "0.6"
nix = "0.14"
-snafu = "0.4"
+snafu = { version = "0.4", features = ["futures-01"] }
tokio = "0.1"
tokio-pty-process = "0.4"