summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJesse Luehrs <doy@tozt.net>2022-03-08 19:58:53 -0500
committerJesse Luehrs <doy@tozt.net>2022-03-08 20:00:46 -0500
commit3a082edd58ecdf4db31702c6c8487c42227049a3 (patch)
tree6cdb3a7b635da5b06e82fc91d7ddba618822843a /Cargo.toml
parent1abb97cca69e0b513f7499cc7db03ba622b38711 (diff)
downloadnbsh-3a082edd58ecdf4db31702c6c8487c42227049a3.tar.gz
nbsh-3a082edd58ecdf4db31702c6c8487c42227049a3.zip
parse a history file if available
doesn't do anything with it yet
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 4 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 3a2f0d9..89b201e 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -27,7 +27,7 @@ terminal_size = "0.1.17"
textmode = { version = "0.3.0", features = ["async"] }
time = { version = "0.3.7", features = ["formatting", "parsing"] }
tokio = { version = "1.17.0", features = ["full"] }
-tokio-stream = "0.1.8"
+tokio-stream = { version = "0.1.8", features = ["io-util"] }
tokio-util = { version = "0.7.0", features = ["io"] }
toml = "0.5.8"
unicode-width = "0.1.9"
@@ -42,3 +42,6 @@ nix = { git = "https://github.com/nix-rust/nix" }
notify = { git = "https://github.com/notify-rs/notify" }
pty-process = { git = "https://github.com/doy/pty-process" }
textmode = { git = "https://github.com/doy/textmode" }
+
+[dev-dependencies]
+time = { version = "0.3.7", features = ["macros"] }