summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJesse Luehrs <doy@tozt.net>2021-12-31 03:37:44 -0500
committerJesse Luehrs <doy@tozt.net>2021-12-31 03:37:44 -0500
commit85e3f0052b9ca5c084a93e8ae9e6cd6d5bc2ee5b (patch)
treebc2bcecf264a1b5ce356e6988ce46e30a2f56bc9 /Cargo.toml
parent1c2486a55c21b323f73c72c0128def0fcac061eb (diff)
downloadnbsh-85e3f0052b9ca5c084a93e8ae9e6cd6d5bc2ee5b.tar.gz
nbsh-85e3f0052b9ca5c084a93e8ae9e6cd6d5bc2ee5b.zip
deps
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml8
1 files changed, 4 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 65b5a6f..e132517 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -6,25 +6,25 @@ edition = "2021"
license = "MIT"
[dependencies]
-anyhow = "1.0.51"
+anyhow = "1.0.52"
async-std = { version = "1.10.0", features = ["unstable"] }
futures-lite = "1.12.0"
futures-util = "0.3.19"
hostname = "0.3.1"
libc = "0.2.112"
-nix = "0.23.0"
+nix = "0.23.1"
once_cell = "1.9.0"
pest = "2.1.3"
pest_derive = "2.1.0"
pty-process = { version = "0.2.0", features = ["async"] }
-signal-hook = "0.3.12"
+signal-hook = "0.3.13"
signal-hook-async-std = "0.2.1"
terminal_size = "0.1.17"
textmode = { version = "0.3.0", features = ["async"] }
time = { version = "0.3.5", features = ["formatting", "parsing"] }
unicode-width = "0.1.9"
users = "0.11.0"
-vt100 = "0.15.0"
+vt100 = "0.15.1"
[patch.crates-io]
# https://github.com/smol-rs/async-process/pull/19