summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJesse Luehrs <doy@tozt.net>2022-02-25 17:32:58 -0500
committerJesse Luehrs <doy@tozt.net>2022-02-25 17:32:58 -0500
commita2462bbaea13f7a3f3eb65e7430b30618bc203b8 (patch)
tree8cb2eab6904c2c9f4138f8221caa947c6b805d3b /Cargo.toml
parent7b66471194490a1421001fd51d073cc6d18848ea (diff)
downloadnbsh-a2462bbaea13f7a3f3eb65e7430b30618bc203b8.tar.gz
nbsh-a2462bbaea13f7a3f3eb65e7430b30618bc203b8.zip
move to tokio
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml20
1 files changed, 11 insertions, 9 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 03430c4..f27b4ba 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -6,16 +6,14 @@ edition = "2021"
license = "MIT"
[dependencies]
-anyhow = "1.0.53"
-async-std = { version = "1.10.0", features = ["unstable"] }
+anyhow = "1.0.55"
bincode = "1.3.3"
-blocking = "1.1.0"
-futures-lite = "1.12.0"
+bytes = "1.1.0"
futures-util = "0.3.21"
-git2 = "0.13.25"
+git2 = "0.14.0"
glob = "0.3.0"
hostname = "0.3.1"
-libc = "0.2.117"
+libc = "0.2.119"
nix = "0.23.1"
notify = "4.0.17"
once_cell = "1.9.0"
@@ -24,16 +22,20 @@ pest = "2.1.3"
pest_derive = "2.1.0"
pty-process = { version = "0.2.0", features = ["async"] }
serde = { version = "1.0.136", features = ["derive"] }
-signal-hook-async-std = "0.2.2"
structopt = { version = "0.3.26", features = ["paw", "wrap_help"] }
terminal_size = "0.1.17"
textmode = { version = "0.3.0", features = ["async"] }
time = { version = "0.3.7", features = ["formatting", "parsing"] }
+tokio = { version = "1.17.0", features = ["full"] }
+tokio-stream = "0.1.8"
+tokio-util = { version = "0.7.0", features = ["io"] }
unicode-width = "0.1.9"
users = "0.11.0"
vt100 = "0.15.1"
[patch.crates-io]
-# https://github.com/smol-rs/async-process/pull/19
-async-process = { git = "https://github.com/doy/async-process" }
+nix = { git = "https://github.com/nix-rust/nix" }
pty-process = { git = "https://github.com/doy/pty-process" }
+textmode = { git = "https://github.com/doy/textmode" }
+
+[features]