summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJesse Luehrs <doy@tozt.net>2021-12-31 00:18:02 -0500
committerJesse Luehrs <doy@tozt.net>2021-12-31 00:18:02 -0500
commita5179c4124e7fd8c4a1b31154d616e7a435477ae (patch)
treed64633e9360f5dc8984f6c87af52fb56f7d07fe8 /Cargo.toml
parente6200649a87a7fdc04ad62b6348068d61f53925a (diff)
downloadnbsh-a5179c4124e7fd8c4a1b31154d616e7a435477ae.tar.gz
nbsh-a5179c4124e7fd8c4a1b31154d616e7a435477ae.zip
update pty_process
and make everything executed in a single command share a pty
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 3 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 1942ac4..47e83d2 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -15,7 +15,7 @@ nix = "0.23.0"
once_cell = "1.9.0"
pest = "2.1.3"
pest_derive = "2.1.0"
-pty-process = { version = "0.2.0", features = ["backend-async-std"] }
+pty-process = { version = "0.2.0", features = ["async"] }
signal-hook = "0.3.12"
signal-hook-async-std = "0.2.1"
terminal_size = "0.1.17"
@@ -27,4 +27,5 @@ vt100 = "0.15.0"
[patch.crates-io]
# https://github.com/smol-rs/async-process/pull/19
-async-process = { git = "https://github.com/doy/async-process", branch = "status-drop" }
+async-process = { git = "https://github.com/doy/async-process" }
+pty-process = { path = "../pty-process" }