summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJesse Luehrs <doy@tozt.net>2022-01-17 23:52:15 -0500
committerJesse Luehrs <doy@tozt.net>2022-01-17 23:52:15 -0500
commita7b16850f2437b015bcec8919586c4d4b070a35e (patch)
tree232d6eb20fcea9a763d0f1147b7c28371fba2d7b /Cargo.toml
parented9b8b345316bb8807ebbf501f19fa4684e5deba (diff)
downloadnbsh-a7b16850f2437b015bcec8919586c4d4b070a35e.tar.gz
nbsh-a7b16850f2437b015bcec8919586c4d4b070a35e.zip
use structopt
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 5bf19fb..99f0202 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -19,11 +19,13 @@ libc = "0.2.112"
nix = "0.23.1"
notify = "4.0.17"
once_cell = "1.9.0"
+paw = "1.0.0"
pest = "2.1.3"
pest_derive = "2.1.0"
pty-process = { version = "0.2.0", features = ["async"] }
serde = { version = "1.0.133", features = ["derive"] }
signal-hook-async-std = "0.2.1"
+structopt = { version = "0.3.25", features = ["paw", "wrap_help"] }
terminal_size = "0.1.17"
textmode = { version = "0.3.0", features = ["async"] }
time = { version = "0.3.5", features = ["formatting", "parsing"] }