summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJesse Luehrs <doy@tozt.net>2022-02-12 12:38:42 -0500
committerJesse Luehrs <doy@tozt.net>2022-02-12 12:38:42 -0500
commitcdc0ba6bcb536ce776872351ed693397a418418b (patch)
tree8a5da47bc21cd65f3c8b13dc6b032f26791ae1b9 /Cargo.toml
parent88cc6c1141eb9e279b73ce0229bf130885836f35 (diff)
downloadnbsh-cdc0ba6bcb536ce776872351ed693397a418418b.tar.gz
nbsh-cdc0ba6bcb536ce776872351ed693397a418418b.zip
deps
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml12
1 files changed, 6 insertions, 6 deletions
diff --git a/Cargo.toml b/Cargo.toml
index cb0cdcc..03430c4 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -6,16 +6,16 @@ edition = "2021"
license = "MIT"
[dependencies]
-anyhow = "1.0.52"
+anyhow = "1.0.53"
async-std = { version = "1.10.0", features = ["unstable"] }
bincode = "1.3.3"
blocking = "1.1.0"
futures-lite = "1.12.0"
-futures-util = "0.3.19"
+futures-util = "0.3.21"
git2 = "0.13.25"
glob = "0.3.0"
hostname = "0.3.1"
-libc = "0.2.112"
+libc = "0.2.117"
nix = "0.23.1"
notify = "4.0.17"
once_cell = "1.9.0"
@@ -23,12 +23,12 @@ paw = "1.0.0"
pest = "2.1.3"
pest_derive = "2.1.0"
pty-process = { version = "0.2.0", features = ["async"] }
-serde = { version = "1.0.133", features = ["derive"] }
+serde = { version = "1.0.136", features = ["derive"] }
signal-hook-async-std = "0.2.2"
-structopt = { version = "0.3.25", features = ["paw", "wrap_help"] }
+structopt = { version = "0.3.26", features = ["paw", "wrap_help"] }
terminal_size = "0.1.17"
textmode = { version = "0.3.0", features = ["async"] }
-time = { version = "0.3.5", features = ["formatting", "parsing"] }
+time = { version = "0.3.7", features = ["formatting", "parsing"] }
unicode-width = "0.1.9"
users = "0.11.0"
vt100 = "0.15.1"