summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJesse Luehrs <doy@tozt.net>2022-03-04 22:08:42 -0500
committerJesse Luehrs <doy@tozt.net>2022-03-04 22:08:42 -0500
commite217b3ee27f75ffc2b27753bc88cca8a9342307b (patch)
treeb4c898324df13e2e94914b9a92171f47879e9a84 /Cargo.toml
parenta47ef825137cdb9a66ae06dbb39ee6bbffd588f2 (diff)
downloadnbsh-e217b3ee27f75ffc2b27753bc88cca8a9342307b.tar.gz
nbsh-e217b3ee27f75ffc2b27753bc88cca8a9342307b.zip
move to clap 3
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 1 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 784e63d..cafc439 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -9,6 +9,7 @@ license = "MIT"
anyhow = "1.0.55"
bincode = "1.3.3"
bytes = "1.1.0"
+clap = { version = "3.1.5", features = ["wrap_help", "derive"] }
futures-util = "0.3.21"
git2 = { version = "0.14.0", default-features = false }
glob = "0.3.0"
@@ -17,12 +18,10 @@ libc = "0.2.119"
nix = "0.23.1"
notify = "4.0.17"
once_cell = "1.9.0"
-paw = "1.0.0"
pest = "2.1.3"
pest_derive = "2.1.0"
pty-process = { version = "0.2.0", features = ["async"] }
serde = { version = "1.0.136", features = ["derive"] }
-structopt = { version = "0.3.26", features = ["paw", "wrap_help"] }
terminal_size = "0.1.17"
textmode = { version = "0.3.0", features = ["async"] }
time = { version = "0.3.7", features = ["formatting", "parsing"] }