summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml40
1 files changed, 24 insertions, 16 deletions
diff --git a/Cargo.toml b/Cargo.toml
index cb0cdcc..89b201e 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -6,34 +6,42 @@ edition = "2021"
license = "MIT"
[dependencies]
-anyhow = "1.0.52"
-async-std = { version = "1.10.0", features = ["unstable"] }
+anyhow = "1.0.55"
bincode = "1.3.3"
-blocking = "1.1.0"
-futures-lite = "1.12.0"
-futures-util = "0.3.19"
-git2 = "0.13.25"
+bytes = "1.1.0"
+clap = { version = "3.1.5", features = ["wrap_help", "derive"] }
+directories = "4.0.1"
+futures-util = "0.3.21"
+git2 = { version = "0.14.1", default-features = false }
glob = "0.3.0"
hostname = "0.3.1"
-libc = "0.2.112"
+libc = "0.2.119"
nix = "0.23.1"
-notify = "4.0.17"
-once_cell = "1.9.0"
-paw = "1.0.0"
+notify = "5.0.0-pre.13"
+once_cell = "1.10.0"
pest = "2.1.3"
pest_derive = "2.1.0"
pty-process = { version = "0.2.0", features = ["async"] }
-serde = { version = "1.0.133", features = ["derive"] }
-signal-hook-async-std = "0.2.2"
-structopt = { version = "0.3.25", features = ["paw", "wrap_help"] }
+serde = { version = "1.0.136", features = ["derive"] }
terminal_size = "0.1.17"
textmode = { version = "0.3.0", features = ["async"] }
-time = { version = "0.3.5", features = ["formatting", "parsing"] }
+time = { version = "0.3.7", features = ["formatting", "parsing"] }
+tokio = { version = "1.17.0", features = ["full"] }
+tokio-stream = { version = "0.1.8", features = ["io-util"] }
+tokio-util = { version = "0.7.0", features = ["io"] }
+toml = "0.5.8"
unicode-width = "0.1.9"
users = "0.11.0"
vt100 = "0.15.1"
+[target.'cfg(nbsh_tokio_console)'.dependencies]
+console-subscriber = "0.1.3"
+
[patch.crates-io]
-# https://github.com/smol-rs/async-process/pull/19
-async-process = { git = "https://github.com/doy/async-process" }
+nix = { git = "https://github.com/nix-rust/nix" }
+notify = { git = "https://github.com/notify-rs/notify" }
pty-process = { git = "https://github.com/doy/pty-process" }
+textmode = { git = "https://github.com/doy/textmode" }
+
+[dev-dependencies]
+time = { version = "0.3.7", features = ["macros"] }