summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 3 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 1942ac4..47e83d2 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -15,7 +15,7 @@ nix = "0.23.0"
once_cell = "1.9.0"
pest = "2.1.3"
pest_derive = "2.1.0"
-pty-process = { version = "0.2.0", features = ["backend-async-std"] }
+pty-process = { version = "0.2.0", features = ["async"] }
signal-hook = "0.3.12"
signal-hook-async-std = "0.2.1"
terminal_size = "0.1.17"
@@ -27,4 +27,5 @@ vt100 = "0.15.0"
[patch.crates-io]
# https://github.com/smol-rs/async-process/pull/19
-async-process = { git = "https://github.com/doy/async-process", branch = "status-drop" }
+async-process = { git = "https://github.com/doy/async-process" }
+pty-process = { path = "../pty-process" }