aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJesse Luehrs <doy@tozt.net>2022-02-22 17:02:12 -0500
committerJesse Luehrs <doy@tozt.net>2022-02-23 02:44:18 -0500
commit39287b07f87aba15c4cb0f64d7008ba67289151d (patch)
treea0ce5fee6e98a7c429f668000d7cdc71cf8d4797 /Cargo.toml
parentebcf5f15081f6a84c861eb2aecbf962396a88695 (diff)
downloadpty-process-39287b07f87aba15c4cb0f64d7008ba67289151d.tar.gz
pty-process-39287b07f87aba15c4cb0f64d7008ba67289151d.zip
another rewrite
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml18
1 files changed, 6 insertions, 12 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 454a226..9f9c202 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -13,27 +13,21 @@ license = "MIT"
include = ["src/**/*", "LICENSE", "README.md", "CHANGELOG.md"]
[dependencies]
-libc = "0.2.112"
+libc = "0.2.119"
nix = "0.23.1"
-async-io = { version = "1.6.0", optional = true }
-async-process = { version = "1.3.0", optional = true }
-futures-io = { version = "0.3.19", optional = true }
+tokio = { version = "1.17.0", features = ["fs", "process", "net"], optional = true }
[dev-dependencies]
-async-executor = "1.4.1"
-async-std = { version = "1.10.0", features = ["unstable"] }
-futures = "0.3.19"
+futures = "0.3.21"
regex = "1.5.4"
-smol = "1.2.5"
term_size = "0.3.2"
-tokio = { version = "1.15.0", features = ["full"] }
-tokio-util = { version = "0.6.9", features = ["compat"] }
+tokio = { version = "1.17.0", features = ["full"] }
[features]
default = []
-async = ["async-io", "async-process", "futures-io"]
+async = ["tokio"]
[patch.crates-io]
-async-process = { git = "https://github.com/doy/async-process" }
+nix = { path = "../src/nix" }