aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJesse Luehrs <doy@tozt.net>2021-12-29 02:55:24 -0500
committerJesse Luehrs <doy@tozt.net>2021-12-29 03:52:12 -0500
commit3b550f5d3dad77a56455352579fae3071b42e86d (patch)
tree393de5f206d227ec71149f478db900291357c456 /Cargo.toml
parentf8780ca1e76286688b74d8a6c64d5fadf3cfd2a1 (diff)
downloadpty-process-3b550f5d3dad77a56455352579fae3071b42e86d.tar.gz
pty-process-3b550f5d3dad77a56455352579fae3071b42e86d.zip
wip another complete refactor
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml17
1 files changed, 7 insertions, 10 deletions
diff --git a/Cargo.toml b/Cargo.toml
index aeefa41..2ff64e1 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -14,28 +14,25 @@ include = ["src/**/*", "LICENSE", "README.md", "CHANGELOG.md"]
[dependencies]
libc = "0.2.112"
-nix = "0.23.0"
+nix = "0.23.1"
async-io = { version = "1.6.0", optional = true }
async-process = { version = "1.3.0", optional = true }
-tokio = { version = "1.14.0", optional = true, features = ["fs", "process", "net"] }
-futures = { version = "0.3.17", optional = true }
+futures-io = { version = "0.3.19", optional = true }
[dev-dependencies]
-async-std = { version = "1.10.0", features = ["unstable"] }
async-executor = "1.4.1"
+async-std = { version = "1.10.0", features = ["unstable"] }
regex = "1.5.4"
smol = "1.2.5"
term_size = "0.3.2"
-tokio = { version = "1.14.0", features = [ "rt-multi-thread", "macros", "io-std", "io-util", "time" ] }
+tokio = { version = "1.15.0", features = ["full"] }
+tokio-util = { version = "0.6.9", features = ["compat"] }
[features]
-default = ["backend-std"]
+default = []
-backend-std = []
-backend-async-std = ["async-io", "async-process"]
-backend-smol = ["async-io", "async-process"]
-backend-tokio = ["tokio", "futures"]
+async = ["async-io", "async-process", "futures-io"]
[patch.crates-io]
async-process = { git = "https://github.com/doy/async-process", branch = "status-drop" }