aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJesse Luehrs <doy@tozt.net>2021-11-10 12:26:31 -0500
committerJesse Luehrs <doy@tozt.net>2021-11-10 12:26:31 -0500
commit9261c1f23265fa1e25ffd46581b427f85bedf474 (patch)
tree62c75c45614dfbd4624c6c934486a37729788c1e /Cargo.toml
parent9d843436ffc583d95beff7660011eabcaf54fb62 (diff)
downloadpty-process-9261c1f23265fa1e25ffd46581b427f85bedf474.tar.gz
pty-process-9261c1f23265fa1e25ffd46581b427f85bedf474.zip
bump deps
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml26
1 files changed, 13 insertions, 13 deletions
diff --git a/Cargo.toml b/Cargo.toml
index e044317..f038732 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -12,22 +12,22 @@ categories = ["asynchronous", "command-line-interface"]
license = "MIT"
[dependencies]
-libc = "0.2"
-nix = "0.20"
-thiserror = "1.0"
+libc = "0.2.107"
+nix = "0.23.0"
+thiserror = "1.0.30"
-async-io = { version = "1.3", optional = true }
-async-process = { version = "1.0", optional = true }
-tokio = { version = "1.2", optional = true, features = ["fs", "process", "net"] }
-futures = { version = "0.3", optional = true }
+async-io = { version = "1.6.0", optional = true }
+async-process = { version = "1.3.0", optional = true }
+tokio = { version = "1.13.0", optional = true, features = ["fs", "process", "net"] }
+futures = { version = "0.3.17", optional = true }
[dev-dependencies]
-async-std = { version = "1.9", features = ["unstable"] }
-async-executor = "1.4"
-regex = "1.4"
-smol = "1.2"
-term_size = "0.3"
-tokio = { version = "1.2", features = [ "rt-multi-thread", "macros", "io-std", "io-util", "time" ] }
+async-std = { version = "1.10.0", features = ["unstable"] }
+async-executor = "1.4.1"
+regex = "1.5.4"
+smol = "1.2.5"
+term_size = "0.3.2"
+tokio = { version = "1.13.0", features = [ "rt-multi-thread", "macros", "io-std", "io-util", "time" ] }
[features]
default = ["backend-std"]