aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJesse Luehrs <doy@tozt.net>2020-05-03 00:21:07 -0400
committerJesse Luehrs <doy@tozt.net>2020-05-03 00:56:21 -0400
commit047550f2368d134c9d5dca60aeb0b56fe151a323 (patch)
tree2ad014146d2214db42f550646379bb2dbd571ff1 /Cargo.toml
parentea6398d5951ef6a5811cf605bfa223b5b1ce08c4 (diff)
downloadrbw-047550f2368d134c9d5dca60aeb0b56fe151a323.tar.gz
rbw-047550f2368d134c9d5dca60aeb0b56fe151a323.zip
move to ring for things that it supports
it doesn't support AES_256_CBC_HMAC_SHA256, so we can't move that over yet (see https://github.com/briansmith/ring/issues/588)
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 1 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 025d76c..52dcb75 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -22,18 +22,15 @@ clap = { version = "2.33", features = ["wrap_help"] }
daemonize = "0.4"
directories = "2.0"
env_logger = "0.7"
-hkdf = "0.8"
-hmac = "0.7"
humantime = "1.3"
log = "0.4"
nix = "0.17"
-pbkdf2 = "0.3"
rand = "0.7"
region = "2.1"
reqwest = { version = "0.10", features = ["blocking", "json"] }
+ring = "0.16"
serde = { version = "1.0", features = ["derive"] }
serde_json = "1.0"
-sha2 = "0.8"
snafu = "0.6"
tempfile = "3.1"
tokio = { version = "0.2", features = ["full"] }