aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJesse Luehrs <doy@tozt.net>2023-02-18 16:00:14 -0500
committerJesse Luehrs <doy@tozt.net>2023-02-18 17:42:27 -0500
commit070955637030076aca30a9afcba95603a4394abc (patch)
treea8f4952ac9f79c048c07bd438be5405ad2c41d63 /Cargo.toml
parent1d68b717e8ae12dfdf8af9c451dbf0d6a8cc6d71 (diff)
downloadrbw-070955637030076aca30a9afcba95603a4394abc.tar.gz
rbw-070955637030076aca30a9afcba95603a4394abc.zip
bump deps
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml61
1 files changed, 31 insertions, 30 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 06a6f84..a81461d 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -13,46 +13,47 @@ license = "MIT"
include = ["src/**/*", "bin/**/*", "LICENSE", "README.md", "CHANGELOG.md"]
[dependencies]
-aes = "0.7.5"
-anyhow = "1.0.53"
+aes = "0.8.2"
+anyhow = "1.0.69"
arrayvec = "0.7.2"
-async-trait = "0.1.52"
+async-trait = "0.1.64"
base32 = "0.4.0"
-base64 = "0.13.0"
-block-modes = "0.8.1"
-block-padding = "0.2.1"
+base64 = "0.21.0"
+block-padding = "0.3.2"
+cbc = { version = "0.1.2", features = ["alloc", "std"] }
daemonize = "0.4.1"
directories = "4.0.1"
-env_logger = "0.9.0"
-hkdf = "0.11.0"
-hmac = { version = "0.11.0", features = ["std"] }
+env_logger = "0.10.0"
+hkdf = "0.12.3"
+hmac = { version = "0.12.1", features = ["std"] }
humantime = "2.1.0"
-libc = "0.2.117"
-log = "0.4.14"
-nix = "0.23.1"
+libc = "0.2.139"
+log = "0.4.17"
+nix = "0.26.2"
paw = "1.0.0"
-pbkdf2 = "0.9.0"
-percent-encoding = "2.1.0"
-rand = "0.8.4"
+pbkdf2 = "0.11.0"
+percent-encoding = "2.2.0"
+pkcs8 = "0.9.0"
+rand = "0.8.5"
region = "3.0.0"
-reqwest = { version = "0.11.9", default-features = false, features = ["blocking", "json", "rustls-tls-native-roots"] }
-rsa = "0.5.0"
-serde = { version = "1.0.136", features = ["derive"] }
-serde_json = "1.0.78"
-serde_path_to_error = "0.1.7"
-serde_repr = "0.1.7"
-sha-1 = "0.9.8"
-sha2 = "0.9.9"
+reqwest = { version = "0.11.14", default-features = false, features = ["blocking", "json", "rustls-tls-native-roots"] }
+rsa = "0.8.1"
+serde = { version = "1.0.152", features = ["derive"] }
+serde_json = "1.0.93"
+serde_path_to_error = "0.1.9"
+serde_repr = "0.1.10"
+sha1 = "0.10.5"
+sha2 = "0.10.6"
structopt = { version = "0.3.26", features = ["paw", "wrap_help"] }
tempfile = "3.3.0"
term_size = "0.3.2"
-textwrap = "0.11.0"
-thiserror = "1.0.30"
-tokio = { version = "1.16.1", features = ["full"] }
-totp-lite = "1.0.3"
-url = "2.2.2"
-uuid = { version = "0.8.2", features = ["v4"] }
-zeroize = "1.4.3"
+textwrap = "0.16.0"
+thiserror = "1.0.38"
+tokio = { version = "1.25.0", features = ["full"] }
+totp-lite = "2.0.0"
+url = "2.3.1"
+uuid = { version = "1.3.0", features = ["v4"] }
+zeroize = "1.5.7"
[package.metadata.deb]
depends = "pinentry"