aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJesse Luehrs <doy@tozt.net>2020-04-07 00:15:40 -0400
committerJesse Luehrs <doy@tozt.net>2020-04-07 00:15:40 -0400
commit0f13f2c6d11934bbaceca4dac4c3ba428aae72b7 (patch)
tree167026cd6eec33d2e752edfefa023ecd11072998 /Cargo.toml
parent95da8880e311d4932fd50febab6ef093e5915051 (diff)
downloadrbw-0f13f2c6d11934bbaceca4dac4c3ba428aae72b7.tar.gz
rbw-0f13f2c6d11934bbaceca4dac4c3ba428aae72b7.zip
make the command line tool automatically spawn the agent
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml8
1 files changed, 5 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index cfd4bfb..fb4a51c 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -6,17 +6,19 @@ edition = "2018"
[dependencies]
aes = "*"
+anyhow = "*"
base64 = "*"
block-modes = "*"
clap = "*"
+daemonize = "*"
directories = "*"
-fs2 = "*"
+env_logger = "*"
hkdf = "*"
hmac = "*"
+log = "*"
+nix = "*"
pbkdf2 = "*"
reqwest = { version = "*", features = ["blocking", "json"] }
-rpassword = "*"
-rprompt = "*"
serde = { version = "*", features = ["derive"] }
serde_json = "*"
sha2 = "*"