aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJesse Luehrs <doy@tozt.net>2024-01-01 17:11:24 -0500
committerJesse Luehrs <doy@tozt.net>2024-01-01 17:18:06 -0500
commit37d7c71fec43f6dbc6347de563df5b20920441da (patch)
treee37b36df62e180712d16c00802427143bb35ffee /Cargo.toml
parent7be78df10dd04b0ac7121c8d0b25d9954ba9a9f6 (diff)
downloadrbw-37d7c71fec43f6dbc6347de563df5b20920441da.tar.gz
rbw-37d7c71fec43f6dbc6347de563df5b20920441da.zip
bump deps, fix cargo deny
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml68
1 files changed, 34 insertions, 34 deletions
diff --git a/Cargo.toml b/Cargo.toml
index b57a208..3c061a3 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -14,57 +14,57 @@ include = ["src/**/*", "bin/**/*", "LICENSE", "README.md", "CHANGELOG.md"]
[dependencies]
aes = "0.8.3"
-anyhow = "1.0.72"
-argon2 = "0.5.1"
+anyhow = "1.0.78"
+argon2 = "0.5.2"
arrayvec = "0.7.4"
-async-trait = "0.1.71"
+async-trait = "0.1.76"
base32 = "0.4.0"
-base64 = "0.21.2"
+base64 = "0.21.5"
block-padding = "0.3.3"
cbc = { version = "0.1.2", features = ["alloc", "std"] }
-clap = { version = "4.3.15", features = ["wrap_help", "derive"] }
-clap_complete = "4.3.2"
+clap = { version = "4.4.12", features = ["wrap_help", "derive"] }
+clap_complete = "4.4.5"
daemonize = "0.5.0"
# TODO: directories 5.0.1 uses MPL code, which isn't license-compatible
# we should switch to something else at some point
directories = "=5.0.0"
-env_logger = "0.10.0"
-futures = "0.3.28"
-futures-channel = "0.3.28"
-futures-util = "0.3.28"
-hkdf = "0.12.3"
+env_logger = "0.10.1"
+futures = "0.3.30"
+futures-channel = "0.3.30"
+futures-util = "0.3.30"
+hkdf = "0.12.4"
hmac = { version = "0.12.1", features = ["std"] }
humantime = "2.1.0"
-libc = "0.2.147"
-log = "0.4.19"
-nix = "0.24.3"
+libc = "0.2.151"
+log = "0.4.20"
+nix = "0.26"
pbkdf2 = "0.12.2"
-percent-encoding = "2.3.0"
+percent-encoding = "2.3.1"
pkcs8 = "0.10.2"
rand = "0.8.5"
region = "3.0.0"
-reqwest = { version = "0.11.18", default-features = false, features = ["blocking", "json", "rustls-tls-native-roots"] }
-rsa = "0.9.2"
-serde = { version = "1.0.171", features = ["derive"] }
-serde_json = "1.0.103"
+reqwest = { version = "0.11.23", default-features = false, features = ["blocking", "json", "rustls-tls-native-roots"] }
+rsa = "0.9.6"
+serde = { version = "1.0.193", features = ["derive"] }
+serde_json = "1.0.109"
serde_path_to_error = "0.1.14"
-serde_repr = "0.1.14"
-sha1 = "0.10.5"
-sha2 = "0.10.7"
-tempfile = "3.6.0"
-terminal_size = "0.2.6"
+serde_repr = "0.1.17"
+sha1 = "0.10.6"
+sha2 = "0.10.8"
+tempfile = "3.9.0"
+terminal_size = "0.3.0"
textwrap = "0.16.0"
-thiserror = "1.0.43"
-tokio = { version = "1.29.1", features = ["full"] }
+thiserror = "1.0.53"
+tokio = { version = "1.35.1", features = ["full"] }
tokio-stream = { version = "0.1.14", features = ["net"] }
-totp-lite = "2.0.0"
-url = "2.4.0"
-uuid = { version = "1.4.1", features = ["v4"] }
-zeroize = "1.6.0"
-copypasta = "0.8.2"
-rmpv = "1.0.0"
-tokio-tungstenite = { version = "0.19.0", features = ["rustls-tls-native-roots"] }
-is-terminal = "0.4.7"
+totp-lite = "2.0.1"
+url = "2.5.0"
+uuid = { version = "1.6.1", features = ["v4"] }
+zeroize = "1.7.0"
+copypasta = "0.10.0"
+rmpv = "1.0.1"
+tokio-tungstenite = { version = "0.20", features = ["rustls-tls-native-roots"] }
+is-terminal = "0.4.10"
[package.metadata.deb]
depends = "pinentry"