aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJesse Luehrs <doy@tozt.net>2021-04-17 22:45:29 -0400
committerJesse Luehrs <doy@tozt.net>2021-04-17 23:50:43 -0400
commit38f0cd43f2cb2f294c7d195481f78e58b35dfb44 (patch)
tree67f0a40bf002c088896ed330e7008939a7b0e483 /Cargo.toml
parentc627737dfa6a30b71e3f7c32cca05675cc7e9b97 (diff)
downloadrbw-38f0cd43f2cb2f294c7d195481f78e58b35dfb44.tar.gz
rbw-38f0cd43f2cb2f294c7d195481f78e58b35dfb44.zip
stop using openssl
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 3 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 8eba338..dabb3ec 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -19,6 +19,7 @@ async-trait = "0.1"
base32 = "0.4"
base64 = "0.13"
block-modes = "0.7"
+block-padding = "0.2"
chbs = "0.1"
daemonize = "0.4"
directories = "3.0"
@@ -30,17 +31,18 @@ libc = "0.2"
log = "0.4"
nix = "0.20"
oath = "0.10"
-openssl = "0.10"
paw = "1.0"
pbkdf2 = "0.7"
percent-encoding = "2.1"
rand = "0.8"
region = "2.2"
reqwest = { version = "0.11", features = ["blocking", "json"] }
+rsa = "0.4"
serde = { version = "1.0", features = ["derive"] }
serde_json = "1.0"
serde_path_to_error = "0.1"
serde_repr = "0.1"
+sha-1 = "0.9"
sha2 = "0.9"
structopt = { version = "0.3", features = ["paw", "wrap_help"] }
tempfile = "3.2"