aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorBernd Schoolmann <mail@quexten.com>2023-03-26 04:20:00 +0200
committerBernd Schoolmann <mail@quexten.com>2023-03-26 04:28:19 +0200
commit7b57f928e5fb345e02f6101d07d5cbbc7e540458 (patch)
tree5207ee6eab126594e2b2af4a12af09ec97165e5c /Cargo.toml
parentfe9cabecd673eb5d409c764ebaf7a76cdcb47139 (diff)
downloadrbw-7b57f928e5fb345e02f6101d07d5cbbc7e540458.tar.gz
rbw-7b57f928e5fb345e02f6101d07d5cbbc7e540458.zip
Switch argon2 implementation to rustcrypto
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 19d11c5..ae6d641 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -15,6 +15,7 @@ include = ["src/**/*", "bin/**/*", "LICENSE", "README.md", "CHANGELOG.md"]
[dependencies]
aes = "0.8.2"
anyhow = "1.0.69"
+argon2 = "0.5.0"
arrayvec = "0.7.2"
async-trait = "0.1.66"
base32 = "0.4.0"
@@ -39,7 +40,6 @@ rand = "0.8.5"
region = "3.0.0"
reqwest = { version = "0.11.14", default-features = false, features = ["blocking", "json", "rustls-tls-native-roots"] }
rsa = "0.8.2"
-rust-argon2 = "1.0.0"
serde = { version = "1.0.154", features = ["derive"] }
serde_json = "1.0.94"
serde_path_to_error = "0.1.10"