aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJesse Luehrs <doy@tozt.net>2020-05-23 16:16:25 -0400
committerJesse Luehrs <doy@tozt.net>2020-05-23 16:16:25 -0400
commit80acb66445a612798ddf74bd6df60b51fd674fa0 (patch)
tree9c6b5fe2cb6bf33c79523a2ab2dcd9d0124c3e32 /Cargo.toml
parentc9473e0b61bc9d8264a6ce939ed74c3d9b8f4db5 (diff)
downloadrbw-80acb66445a612798ddf74bd6df60b51fd674fa0.tar.gz
rbw-80acb66445a612798ddf74bd6df60b51fd674fa0.zip
better error messages when parsing a server message
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index f2decf3..e3bb413 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -15,6 +15,7 @@ license = "MIT"
aes = "0.3"
anyhow = "1.0"
arrayvec = "0.5"
+async-trait = "0.1"
base64 = "0.12"
block-modes = "0.3"
chbs = "0.0.10"
@@ -34,6 +35,7 @@ reqwest = { version = "0.10", features = ["blocking", "json"] }
ring = "0.16"
serde = { version = "1.0", features = ["derive"] }
serde_json = "1.0"
+serde_path_to_error = "0.1"
snafu = "0.6"
structopt = { version = "0.3", features = ["paw"] }
tempfile = "3.1"