aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJesse Luehrs <doy@tozt.net>2021-07-05 12:45:15 -0400
committerJesse Luehrs <doy@tozt.net>2021-07-05 14:56:31 -0400
commit8e829e612afd9ad7b0a5e2e8594d6981fdedea63 (patch)
tree56353b436e0346815cc5084343f3951aaa1d7555 /Cargo.toml
parent4fa073afca3f449271b8d70e759e4584e060f26d (diff)
downloadrbw-8e829e612afd9ad7b0a5e2e8594d6981fdedea63.tar.gz
rbw-8e829e612afd9ad7b0a5e2e8594d6981fdedea63.zip
bump deps
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml18
1 files changed, 9 insertions, 9 deletions
diff --git a/Cargo.toml b/Cargo.toml
index fe9e5ad..9feef87 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -12,27 +12,27 @@ categories = ["command-line-utilities", "cryptography"]
license = "MIT"
[dependencies]
-aes = "0.6"
+aes = "0.7"
anyhow = "1.0"
arrayvec = "0.7"
async-trait = "0.1"
base32 = "0.4"
base64 = "0.13"
-block-modes = "0.7"
+block-modes = "0.8"
block-padding = "0.2"
chbs = "0.1"
daemonize = "0.4"
directories = "3.0"
env_logger = "0.8"
-hkdf = "0.10"
-hmac = { version = "0.10", features = ["std"] }
+hkdf = "0.11"
+hmac = { version = "0.11", features = ["std"] }
humantime = "2.1"
libc = "0.2"
log = "0.4"
-nix = "0.20"
+nix = "0.21"
oath = "0.10"
paw = "1.0"
-pbkdf2 = "0.7"
+pbkdf2 = "0.8"
percent-encoding = "2.1"
rand = "0.8"
region = "2.2"
@@ -47,12 +47,12 @@ sha2 = "0.9"
structopt = { version = "0.3", features = ["paw", "wrap_help"] }
tempfile = "3.2"
term_size = "0.3"
-textwrap = "0.13"
+textwrap = "0.14"
thiserror = "1.0"
-tokio = { version = "1.5", features = ["full"] }
+tokio = { version = "1.8", features = ["full"] }
url = "2.2"
uuid = { version = "0.8", features = ["v4"] }
-zeroize = "1.2"
+zeroize = "1.3"
[package.metadata.deb]
depends = "pinentry"