aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJesse Luehrs <doy@tozt.net>2023-03-09 20:43:27 -0500
committerJesse Luehrs <doy@tozt.net>2023-03-09 20:55:01 -0500
commitbe2e4aa459222a8194163fff92ccbedcafd6cb19 (patch)
tree79ee6a74f8061ccf46b09baaf8715f56e2f2f3fb /Cargo.toml
parent7729e435241f16e4707fe858c6ace15bd6049c34 (diff)
downloadrbw-be2e4aa459222a8194163fff92ccbedcafd6cb19.tar.gz
rbw-be2e4aa459222a8194163fff92ccbedcafd6cb19.zip
bump deps
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml28
1 files changed, 14 insertions, 14 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 75b10bb..703a3ba 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -16,40 +16,40 @@ include = ["src/**/*", "bin/**/*", "LICENSE", "README.md", "CHANGELOG.md"]
aes = "0.8.2"
anyhow = "1.0.69"
arrayvec = "0.7.2"
-async-trait = "0.1.64"
+async-trait = "0.1.66"
base32 = "0.4.0"
base64 = "0.21.0"
block-padding = "0.3.2"
cbc = { version = "0.1.2", features = ["alloc", "std"] }
-clap = { version = "4.1.6", features = ["wrap_help", "derive"] }
-clap_complete = "4.1.2"
-daemonize = "0.4.1"
+clap = { version = "4.1.8", features = ["wrap_help", "derive"] }
+clap_complete = "4.1.4"
+daemonize = "0.5.0"
directories = "4.0.1"
env_logger = "0.10.0"
hkdf = "0.12.3"
hmac = { version = "0.12.1", features = ["std"] }
humantime = "2.1.0"
-libc = "0.2.139"
+libc = "0.2.140"
log = "0.4.17"
nix = "0.26.2"
-pbkdf2 = "0.11.0"
+pbkdf2 = "0.12.1"
percent-encoding = "2.2.0"
pkcs8 = "0.9.0"
rand = "0.8.5"
region = "3.0.0"
reqwest = { version = "0.11.14", default-features = false, features = ["blocking", "json", "rustls-tls-native-roots"] }
-rsa = "0.8.1"
-serde = { version = "1.0.152", features = ["derive"] }
-serde_json = "1.0.93"
-serde_path_to_error = "0.1.9"
-serde_repr = "0.1.10"
+rsa = "0.8.2"
+serde = { version = "1.0.154", features = ["derive"] }
+serde_json = "1.0.94"
+serde_path_to_error = "0.1.10"
+serde_repr = "0.1.11"
sha1 = "0.10.5"
sha2 = "0.10.6"
-tempfile = "3.3.0"
+tempfile = "3.4.0"
terminal_size = "0.2.5"
textwrap = "0.16.0"
-thiserror = "1.0.38"
-tokio = { version = "1.25.0", features = ["full"] }
+thiserror = "1.0.39"
+tokio = { version = "1.26.0", features = ["full"] }
totp-lite = "2.0.0"
url = "2.3.1"
uuid = { version = "1.3.0", features = ["v4"] }