aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJesse Luehrs <doy@tozt.net>2020-04-19 06:14:07 -0400
committerJesse Luehrs <doy@tozt.net>2020-04-19 06:14:07 -0400
commitd61ba750f305269c260d415a8e79c32292b3c703 (patch)
tree1fb422ba4422919ff0501aceb866833d9589c281 /Cargo.toml
parente323935ae8bd89560c0cdc6d6e6f873b0072650a (diff)
downloadrbw-d61ba750f305269c260d415a8e79c32292b3c703.tar.gz
rbw-d61ba750f305269c260d415a8e79c32292b3c703.zip
add explicit dependency versions
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml54
1 files changed, 27 insertions, 27 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 4e3ac4d..7084172 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -5,30 +5,30 @@ authors = ["Jesse Luehrs <doy@tozt.net>"]
edition = "2018"
[dependencies]
-aes = "*"
-anyhow = "*"
-arrayvec = "*"
-base64 = "*"
-block-modes = "*"
-chbs = "*"
-clap = "*"
-daemonize = "*"
-directories = "*"
-env_logger = "*"
-hkdf = "*"
-hmac = "*"
-humantime = "*"
-log = "*"
-nix = "*"
-pbkdf2 = "*"
-rand = "*"
-region = "*"
-reqwest = { version = "*", features = ["blocking", "json"] }
-serde = { version = "*", features = ["derive"] }
-serde_json = "*"
-sha2 = "*"
-snafu = "*"
-tempfile = "*"
-tokio = { version = "*", features = ["full"] }
-uuid = { version = "*", features = ["v4"] }
-zeroize = "*"
+aes = "0.3"
+anyhow = "1.0"
+arrayvec = "0.5"
+base64 = "0.11"
+block-modes = "0.3"
+chbs = "0.0.10"
+clap = "2.33"
+daemonize = "0.4"
+directories = "2.0"
+env_logger = "0.7"
+hkdf = "0.8"
+hmac = "0.7"
+humantime = "1.3"
+log = "0.4"
+nix = "0.17"
+pbkdf2 = "0.3"
+rand = "0.7"
+region = "2.1"
+reqwest = { version = "0.10", features = ["blocking", "json"] }
+serde = { version = "1.0", features = ["derive"] }
+serde_json = "1.0"
+sha2 = "0.8"
+snafu = "0.6"
+tempfile = "3.1"
+tokio = { version = "0.2", features = ["full"] }
+uuid = { version = "0.8", features = ["v4"] }
+zeroize = "1.1"