aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 4 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 45f2015..8eba338 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -23,6 +23,8 @@ chbs = "0.1"
daemonize = "0.4"
directories = "3.0"
env_logger = "0.8"
+hkdf = "0.10"
+hmac = { version = "0.10", features = ["std"] }
humantime = "2.1"
libc = "0.2"
log = "0.4"
@@ -30,15 +32,16 @@ nix = "0.20"
oath = "0.10"
openssl = "0.10"
paw = "1.0"
+pbkdf2 = "0.7"
percent-encoding = "2.1"
rand = "0.8"
region = "2.2"
reqwest = { version = "0.11", features = ["blocking", "json"] }
-ring = "0.16"
serde = { version = "1.0", features = ["derive"] }
serde_json = "1.0"
serde_path_to_error = "0.1"
serde_repr = "0.1"
+sha2 = "0.9"
structopt = { version = "0.3", features = ["paw", "wrap_help"] }
tempfile = "3.2"
term_size = "0.3"