aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJesse Luehrs <doy@tozt.net>2019-10-09 06:41:40 -0400
committerJesse Luehrs <doy@tozt.net>2019-10-09 06:50:58 -0400
commit2236910dfa4b35158167fa185411602a8da2cd26 (patch)
tree6b3b56e2b2b075dc4b225a6413d7ad1591653409 /Cargo.toml
parent4b0513a7da2f5dad582b6d17cef2d530ce9d0489 (diff)
downloadteleterm-2236910dfa4b35158167fa185411602a8da2cd26.tar.gz
teleterm-2236910dfa4b35158167fa185411602a8da2cd26.zip
better client reconnect handling
make sure we always use the reconnect timer, even in cases where we successfully log in before the connection gets dropped, and use exponential backoff for reconnect attempts
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index b58e558..0ac207e 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -10,6 +10,7 @@ clap = "2"
crossterm = "0.11"
futures = "0.1"
mio = "0.6"
+rand = "0.7"
snafu = { version = "0.5", features = ["futures-01"] }
tokio = "0.1"
tokio-pty-process = "0.4"