aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJesse Luehrs <doy@tozt.net>2019-10-15 15:24:54 -0400
committerJesse Luehrs <doy@tozt.net>2019-10-15 15:29:17 -0400
commit37a9610d346c8ab0f3721dccab7d12ebd933294b (patch)
tree99eb0ccacf926cca7a8b6aa873bbaab8099d1b11 /Cargo.toml
parent113fb3a122c53545b87f233f972e739790b371b8 (diff)
downloadteleterm-37a9610d346c8ab0f3721dccab7d12ebd933294b.tar.gz
teleterm-37a9610d346c8ab0f3721dccab7d12ebd933294b.zip
start implementing oauth authentication
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml7
1 files changed, 7 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 499bef9..f8f8f0f 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -10,17 +10,24 @@ clap = "2"
crossterm = "0.11"
env_logger = "0.7"
futures = "0.1"
+lazy_static = "1"
log = "0.4"
mio = "0.6"
native-tls = "0.2"
+oauth2 = "3.0.0-alpha.3"
+open = "1"
rand = "0.7"
ratelimit_meter = "5"
+regex = "1"
+reqwest = "0.9"
+serde = "1"
snafu = { version = "0.5", features = ["futures-01"] }
tokio = "0.1"
tokio-pty-process = "0.4"
tokio-signal = "0.2"
tokio-tls = "0.2"
twoway = "0.2"
+url = "1"
uuid = { version = "0.7", features = ["v4"] }
[[bin]]