aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJesse Luehrs <doy@tozt.net>2019-10-09 14:40:39 -0400
committerJesse Luehrs <doy@tozt.net>2019-10-09 14:40:39 -0400
commit7cfb0e9fb0a602f57bf3b03130998b0c8757d2e1 (patch)
tree418e21bf0dcfdad77e18bc88cc862cd87f4c943d /Cargo.toml
parentd07178d9fff5cb5af2c9308557ce46350ca7d547 (diff)
downloadteleterm-7cfb0e9fb0a602f57bf3b03130998b0c8757d2e1.tar.gz
teleterm-7cfb0e9fb0a602f57bf3b03130998b0c8757d2e1.zip
basic rate limiting
for now, it just closes down connections if a single user is being too spammy (other than with TerminalOutput messages). this is better than nothing, but overall doesn't really do a whole lot - it'll probably need some amount of tweaking.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 0ac207e..1c88a81 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -11,6 +11,7 @@ crossterm = "0.11"
futures = "0.1"
mio = "0.6"
rand = "0.7"
+ratelimit_meter = "5"
snafu = { version = "0.5", features = ["futures-01"] }
tokio = "0.1"
tokio-pty-process = "0.4"