aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJesse Luehrs <doy@tozt.net>2019-11-15 12:53:58 -0500
committerJesse Luehrs <doy@tozt.net>2019-11-15 12:53:58 -0500
commitfe4fa53dbbb6030beae2094e33d1db008532ae3c (patch)
tree645c4b0311ac6d0406c10c54a5daa9279ed588d0 /Cargo.toml
parent69f9306c874f52ecee1f083b0a1075d3f4e175f4 (diff)
downloadteleterm-fe4fa53dbbb6030beae2094e33d1db008532ae3c.tar.gz
teleterm-fe4fa53dbbb6030beae2094e33d1db008532ae3c.zip
add basic websocket server implementation
based on example in the gotham repo - ugly, but it's what is supported for now
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml7
1 files changed, 6 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index ea350b8..f1e0ed0 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -12,6 +12,7 @@ categories = ["command-line-utilities"]
license = "MIT"
[dependencies]
+base64 = "0.11"
bytes = "0.4"
clap = { version = "2", features = ["wrap_help"] }
component-future = "0.1"
@@ -20,7 +21,9 @@ crossterm = { version = "0.13", features = ["terminal", "input", "screen"], defa
directories = "2"
env_logger = "0.7"
futures = "0.1.29"
-gotham = "0.4"
+# for websocket support - should be able to go back to released version in 0.5
+gotham = { git = "https://github.com/gotham-rs/gotham", rev = "d2395926b93710832f8d72b49c9bd3e77516e386" }
+hyper = "0.12"
lazy_static = "1"
log = { version = "0.4", features = ["release_max_level_info"] }
mio = "0.6.19"
@@ -32,12 +35,14 @@ ratelimit_meter = "5"
regex = { version = "1", features = ["std", "perf"], default_features = false }
reqwest = "0.9.22"
serde = "1"
+sha1 = "0.6"
snafu = { version = "0.5", features = ["rust_1_30", "futures-01"], default_features = false }
tokio = { version = "0.1.22", features = ["codec", "fs", "io", "reactor", "rt-full", "sync", "tcp", "timer"], default_features = false }
tokio-pty-process-stream = "0.2"
tokio-signal = "0.2"
tokio-terminal-resize = "0.1"
tokio-tls = "0.2"
+tokio-tungstenite = "0.9"
ttyrec = "0.2"
twoway = "0.2"
url = "2"