aboutsummaryrefslogtreecommitdiffstats
path: root/teleterm-web/Cargo.toml
diff options
context:
space:
mode:
authorJesse Luehrs <doy@tozt.net>2019-11-22 03:19:02 -0500
committerJesse Luehrs <doy@tozt.net>2019-11-22 03:19:02 -0500
commitd3fe70943c0957c977b44965fe300f6c1b101e32 (patch)
tree1f3347d4059a15307ca79f43842ceabdcbee249f /teleterm-web/Cargo.toml
parent29c8f1ae0a54e0dcceb3eac42a2e4e033f1918c4 (diff)
downloadteleterm-d3fe70943c0957c977b44965fe300f6c1b101e32.tar.gz
teleterm-d3fe70943c0957c977b44965fe300f6c1b101e32.zip
implement listing and watching on the web side
watching doesn't do anything yet, because the server side doesn't yet know how to send messages to a watch client
Diffstat (limited to 'teleterm-web/Cargo.toml')
-rw-r--r--teleterm-web/Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/teleterm-web/Cargo.toml b/teleterm-web/Cargo.toml
index 7a9a7f9..57a7d25 100644
--- a/teleterm-web/Cargo.toml
+++ b/teleterm-web/Cargo.toml
@@ -11,7 +11,10 @@ publish = false
crate-type = ["cdylib", "rlib"]
[dependencies]
+futures = "0.1.29"
js-sys = "0.3"
seed = "0.4"
+serde = "1"
+serde_json = "1"
wasm-bindgen = "0.2"
web-sys = { version = "0.3", features = ["ErrorEvent", "MessageEvent", "WebSocket"] }