aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJesse Luehrs <doy@tozt.net>2022-02-24 16:34:56 -0500
committerJesse Luehrs <doy@tozt.net>2022-02-24 16:34:56 -0500
commit193e1963afc4e9e78122573cd5b9831f9a847345 (patch)
treeb8b4ea3df07a4df99103e17cdc07419d88fbec9e /Cargo.toml
parent3df7202f1daf634a49e88dd2ecd8587bade0baeb (diff)
downloadtextmode-193e1963afc4e9e78122573cd5b9831f9a847345.tar.gz
textmode-193e1963afc4e9e78122573cd5b9831f9a847345.zip
go back to not using tokio::select!
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 5d7b5be..da176ef 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -27,10 +27,13 @@ async = ["tokio"]
[dev-dependencies]
assert_cmd = "2.0.4"
assert_fs = "1.0.7"
+bytes = "1.1.0"
escargot = "0.5.7"
+futures = "0.3.21"
libc = "0.2.119"
pty-process = { version = "0.2.0", features = ["async"] }
tokio = { version = "1.17.0", features = ["full"] }
+tokio-util = { version = "0.7.0", features = ["io"] }
[patch.crates-io]
nix = { git = "https://github.com/nix-rust/nix" }