aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJesse Luehrs <doy@tozt.net>2022-02-24 02:42:25 -0500
committerJesse Luehrs <doy@tozt.net>2022-02-24 02:50:33 -0500
commit246ae0894d4074c38ea2d2eb520e386b0d36d82d (patch)
treed2e681e4df655a63519193d0b797b09d0afdd4cc /Cargo.toml
parentcd617e021bed862ac3794cc71123959c8d7d7dd1 (diff)
downloadtextmode-246ae0894d4074c38ea2d2eb520e386b0d36d82d.tar.gz
textmode-246ae0894d4074c38ea2d2eb520e386b0d36d82d.zip
move to tokio
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml23
1 files changed, 13 insertions, 10 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 085302c..7d82025 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -14,21 +14,24 @@ include = ["src/**/*", "LICENSE", "README.md", "CHANGELOG.md"]
[dependencies]
itoa = "1.0.1"
-nix = "0.23.0"
+nix = "0.23.1"
terminal_size = "0.1.17"
-vt100 = "0.15.0"
+vt100 = "0.15.1"
-blocking = { version = "1.1.0", optional = true }
-futures-lite = { version = "1.12.0", optional = true }
+tokio = { version = "1.17.0", features = ["io-std", "io-util", "rt", "rt-multi-thread"], optional = true }
[features]
default = []
-async = ["blocking", "futures-lite"]
+async = ["tokio"]
[dev-dependencies]
-assert_cmd = "2.0.2"
-assert_fs = "1.0.6"
+assert_cmd = "2.0.4"
+assert_fs = "1.0.7"
escargot = "0.5.7"
-libc = "0.2.112"
-pty-process = { version = "0.2.0", features = ["backend-smol"] }
-smol = "1.2.5"
+libc = "0.2.119"
+pty-process = { version = "0.2.0", features = ["async"] }
+tokio = { version = "1.17.0", features = ["full"] }
+
+[patch.crates-io]
+nix = { path = "../src/nix" }
+pty-process = { path = "../pty-process" }