aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJesse Luehrs <doy@tozt.net>2023-03-08 12:58:51 -0500
committerJesse Luehrs <doy@tozt.net>2023-03-08 12:58:51 -0500
commitdcceb025761d379e18111043eb2101e112addb71 (patch)
tree8b8e7aafc0b5e863749cb2642fc29302657eadea /Cargo.toml
parent5dd712dbda2007fe16d9addc2497f72593df7a47 (diff)
downloadtextmode-dcceb025761d379e18111043eb2101e112addb71.tar.gz
textmode-dcceb025761d379e18111043eb2101e112addb71.zip
bump deps
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml30
1 files changed, 13 insertions, 17 deletions
diff --git a/Cargo.toml b/Cargo.toml
index da176ef..af0c80a 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -13,28 +13,24 @@ license = "MIT"
include = ["src/**/*", "LICENSE", "README.md", "CHANGELOG.md"]
[dependencies]
-itoa = "1.0.1"
-nix = "0.23.1"
-terminal_size = "0.1.17"
-vt100 = "0.15.1"
+itoa = "1.0.6"
+nix = "0.26.2"
+terminal_size = "0.2.5"
+vt100 = "0.15.2"
-tokio = { version = "1.17.0", features = ["io-std", "io-util", "rt", "rt-multi-thread"], optional = true }
+tokio = { version = "1.26.0", features = ["io-std", "io-util", "rt", "rt-multi-thread"], optional = true }
[features]
default = []
async = ["tokio"]
[dev-dependencies]
-assert_cmd = "2.0.4"
-assert_fs = "1.0.7"
-bytes = "1.1.0"
+assert_cmd = "2.0.8"
+assert_fs = "1.0.10"
+bytes = "1.4.0"
escargot = "0.5.7"
-futures = "0.3.21"
-libc = "0.2.119"
-pty-process = { version = "0.2.0", features = ["async"] }
-tokio = { version = "1.17.0", features = ["full"] }
-tokio-util = { version = "0.7.0", features = ["io"] }
-
-[patch.crates-io]
-nix = { git = "https://github.com/nix-rust/nix" }
-pty-process = { git = "https://github.com/doy/pty-process" }
+futures = "0.3.26"
+libc = "0.2.139"
+pty-process = { version = "0.3.0", features = ["async"] }
+tokio = { version = "1.26.0", features = ["full"] }
+tokio-util = { version = "0.7.7", features = ["io"] }