aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJesse Luehrs <doy@tozt.net>2021-12-04 02:20:11 -0500
committerJesse Luehrs <doy@tozt.net>2021-12-04 02:20:11 -0500
commit1d9aea0ad68c5dc41e8c421b05440d1237dd1ee4 (patch)
tree9c622d6f0f5247469b6b27d8db79916e1c9a393c /Cargo.toml
parent33cc13b554e6f4cc6e139b0eecf5c6e697433a9d (diff)
downloadttyrec-bin-1d9aea0ad68c5dc41e8c421b05440d1237dd1ee4.tar.gz
ttyrec-bin-1d9aea0ad68c5dc41e8c421b05440d1237dd1ee4.zip
handle terminal resizing
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index ebdb3f9..1802667 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -11,6 +11,8 @@ async-std = { version = "1.10.0", features = ["unstable"] }
libc = "0.2.108"
paw = "1.0.0"
pty-process = { version = "0.1.1", features = ["backend-async-std"] }
+signal-hook = "0.3.10"
+signal-hook-async-std = "0.2.1"
structopt = { version = "0.3.25", features = ["paw", "wrap_help"] }
terminal_size = "0.1.17"
textmode = { version = "0.2.0", features = ["async"] }