aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJesse Luehrs <doy@tozt.net>2023-03-08 14:10:48 -0500
committerJesse Luehrs <doy@tozt.net>2023-03-08 14:10:48 -0500
commitaa08ecf2c465260048c7e5eac86a47f201e635c7 (patch)
treed309cec31548cc7125b951ca871e1d7b02baa680 /Cargo.toml
parentc7729f3522701248e1584e13ed08ec677aa42580 (diff)
downloadttyrec-bin-aa08ecf2c465260048c7e5eac86a47f201e635c7.tar.gz
ttyrec-bin-aa08ecf2c465260048c7e5eac86a47f201e635c7.zip
remove more select! use
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 0cdd3f9..1defd82 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -14,6 +14,7 @@ include = ["src/**/*", "LICENSE", "README.md", "CHANGELOG.md"]
[dependencies]
anyhow = "1.0.69"
+bytes = "1.4.0"
clap = { version = "4.1.8", features = ["wrap_help", "derive"] }
futures-util = "0.3.26"
libc = "0.2.139"
@@ -21,5 +22,7 @@ pty-process = { version = "0.3.0", features = ["async"] }
terminal_size = "0.2.5"
textmode = { version = "0.4.0", features = ["async"] }
tokio = { version = "1.26.0", features = ["full"] }
+tokio-stream = { version = "0.1.12", features = ["io-util"] }
+tokio-util = { version = "0.7.7", features = ["io"] }
ttyrec = { version = "0.4.0", features = ["async"] }
vt100 = "0.15.2"