aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml20
1 files changed, 12 insertions, 8 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 6cc8f90..7df863a 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -13,15 +13,19 @@ license = "MIT"
include = ["src/**/*", "LICENSE", "README.md", "CHANGELOG.md"]
[dependencies]
-anyhow = "1.0.51"
-async-std = { version = "1.10.0", features = ["unstable"] }
-libc = "0.2.112"
+anyhow = "1.0.55"
+libc = "0.2.119"
paw = "1.0.0"
-pty-process = { version = "0.2.0", features = ["backend-async-std"] }
-signal-hook = "0.3.12"
-signal-hook-async-std = "0.2.1"
-structopt = { version = "0.3.25", features = ["paw", "wrap_help"] }
+pty-process = { version = "0.2.0", features = ["async"] }
+structopt = { version = "0.3.26", features = ["paw", "wrap_help"] }
terminal_size = "0.1.17"
textmode = { version = "0.3.0", features = ["async"] }
+tokio = { version = "1.17.0", features = ["full"] }
ttyrec = { version = "0.3.3", features = ["async"] }
-vt100 = "0.15.0"
+vt100 = "0.15.1"
+
+[patch.crates-io]
+nix = { path = "../src/nix" }
+pty-process = { path = "../pty-process" }
+textmode = { path = "../textmode" }
+ttyrec = { path = "../ttyrec" }