aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJesse Luehrs <doy@tozt.net>2021-12-03 19:43:06 -0500
committerJesse Luehrs <doy@tozt.net>2021-12-03 19:43:06 -0500
commit8a98d4fee2172d5ac53e74bcc95cd39aa68492a3 (patch)
tree10fb97bbd275fc1ea6a1e69300e7ba1bc1e35430 /Cargo.toml
parent22b2262bdc097ac6ddbe4c7ce488b1afb4f9127e (diff)
downloadttyrec-8a98d4fee2172d5ac53e74bcc95cd39aa68492a3.tar.gz
ttyrec-8a98d4fee2172d5ac53e74bcc95cd39aa68492a3.zip
remove async stuff, clean up everything else
will reintroduce the async stuff in a future commit
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml9
1 files changed, 1 insertions, 8 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 86cb64e..98104c8 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -2,7 +2,7 @@
name = "ttyrec"
version = "0.2.0"
authors = ["Jesse Luehrs <doy@tozt.net>"]
-edition = "2018"
+edition = "2021"
description = "reads and writes ttyrec files"
license = "MIT"
@@ -12,10 +12,3 @@ keywords = ["ttyrec"]
categories = ["parser-implementations"]
[dependencies]
-futures = { version = "0.1.29", optional = true }
-snafu = "0.5"
-tokio = { version = "0.1.22", optional = true }
-
-[features]
-default = ["async"]
-async = ["tokio", "futures"]