aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml9
1 files changed, 1 insertions, 8 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 86cb64e..98104c8 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -2,7 +2,7 @@
name = "ttyrec"
version = "0.2.0"
authors = ["Jesse Luehrs <doy@tozt.net>"]
-edition = "2018"
+edition = "2021"
description = "reads and writes ttyrec files"
license = "MIT"
@@ -12,10 +12,3 @@ keywords = ["ttyrec"]
categories = ["parser-implementations"]
[dependencies]
-futures = { version = "0.1.29", optional = true }
-snafu = "0.5"
-tokio = { version = "0.1.22", optional = true }
-
-[features]
-default = ["async"]
-async = ["tokio", "futures"]