aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJesse Luehrs <doy@tozt.net>2019-12-07 02:01:53 -0500
committerJesse Luehrs <doy@tozt.net>2019-12-07 02:07:11 -0500
commit1075c2888dffb261164d1f3c5a5d216c4a3f0d35 (patch)
treef91d45e28da8ef705e00d826c121a81851c32698 /Cargo.toml
parentc4d890090e20a2c3b7c6eb03feb2f6e6033c9caf (diff)
downloadvt100-rust-1075c2888dffb261164d1f3c5a5d216c4a3f0d35.tar.gz
vt100-rust-1075c2888dffb261164d1f3c5a5d216c4a3f0d35.zip
actually, remove normalization entirely
normalization has some weird edge cases that cause incorrect behavior, since we aren't implementing full grapheme segmentation (for instance, a single codepoint can be normalized into three different codepoints, and there are codepoints that are combining characters but have width != 0)
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 0 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 9e60834..14d7774 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -12,14 +12,10 @@ keywords = ["terminal", "vt100"]
categories = ["command-line-interface", "encoding"]
license = "MIT"
-[features]
-default = ["unicode-normalization"]
-
[dependencies]
itoa = "0.4"
enumset = "0.4"
log = "0.4"
-unicode-normalization = { version = "0.1", optional = true }
unicode-width = "0.1"
vte = "0.3"