aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJesse Luehrs <doy@tozt.net>2023-08-06 18:30:40 -0400
committerJesse Luehrs <doy@tozt.net>2023-08-06 18:30:40 -0400
commit54e8bf4f2e91407be2054cd38fea81ba830303fd (patch)
tree2ee35f81282d8af91450969f89b42623fd11ec3d /Cargo.toml
parentdb967551c7d7ee4f38b4fb6ee8d4dd998ad9c871 (diff)
downloadpty-process-54e8bf4f2e91407be2054cd38fea81ba830303fd.tar.gz
pty-process-54e8bf4f2e91407be2054cd38fea81ba830303fd.zip
convert to rustix
it seems more maintained, and hopefully this will fix compile issues on macos
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 25e2693..f6c4e07 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -14,12 +14,13 @@ include = ["src/**/*", "LICENSE", "README.md", "CHANGELOG.md"]
[dependencies]
libc = "0.2.147"
-nix = "0.26.2"
+rustix = { version = "0.38.7", features = ["pty", "process", "fs"] }
tokio = { version = "1.29.1", features = ["fs", "process", "net"], optional = true }
[dev-dependencies]
futures = "0.3.28"
+nix = { version = "0.26.2", default-features = false, features = ["signal", "fs", "term", "poll"] }
regex = "1.9.3"
tokio = { version = "1.29.1", features = ["full"] }