aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJesse Luehrs <doy@tozt.net>2021-02-22 04:00:53 -0500
committerJesse Luehrs <doy@tozt.net>2021-02-22 04:01:25 -0500
commit5b526af7c0d86158bc0bfc7db0e73dea3bc83cfe (patch)
tree7935a1efedc5e811d01994016eef47bf0c21a4af /Cargo.toml
parentedfffc8c490b9d179a62901dfb874a85ab0984e3 (diff)
downloadpty-process-5b526af7c0d86158bc0bfc7db0e73dea3bc83cfe.tar.gz
pty-process-5b526af7c0d86158bc0bfc7db0e73dea3bc83cfe.zip
add implementations for async-std and tokio
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml8
1 files changed, 8 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index d1673b2..27e5bf1 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -8,3 +8,11 @@ edition = "2018"
libc = "*"
nix = "0.17"
thiserror = "1.0"
+
+async-process = { version = "1.0", optional = true }
+tokio = { version = "1.2", optional = true, features = ["process"] }
+
+[features]
+default = ["std"]
+
+std = []